备忘:纯IPv6条件下安装CyberPanel建立个人博客
本文最后更新于152 天前,其中的信息可能已经过时,如有错误请发送邮件到[email protected],亦或是留言提醒站长!你也可以通过 https://t.me/shiinabulog 联系我!

首先,都上IPV6-Only了,咱也不考虑什么优化,什么直连了,直接先上CloudFlare确保能够v4访问再说

CyberPanel是少数几个支持LiteSpeed的面板,而LiteSpeed在Wordpress上的表现极佳,所以对于小机器来说,LiteSpeed类算是一个首选(?)

01 – Installing CyberPanel – Docs / 01 – Install/Upgrade – CyberPanel Community

第一步是安装CyberPanel,CyberPanel只支持以下系统,WP部署完毕后内存占用为400MB,所以512内存的机子还可以进一步使用SQLite进行优化

  • Server with a fresh install of Ubuntu 20.04, Ubuntu 22.04, CloudLinux 7, CloudLinux 8, AlmaLinux 8.
 sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)

不想进网站的可以直接使用以上命令安装,选项根据需求自行选择

如果能够正常安装,则不用管,等待安装完毕访问https://[]:8090即可

如果出现连接问题/“no premission”则大概率是IPv6无法访问,装个WARP再次安装即可

第二步是访问面板,访问面板时可能会出现问题,由于LSCPD可能没办法自动监听IPv6,所以可能需要自己去修改文件

 nano(vim/vi) /usr/local/lscp/conf/bind.conf
#在里面加入以下
[::]:8090
*:8090

#重启LSCPD
systemctl restart lscpd

这时候再通过IPv6访问CyberPanel面板大概率是可行的,进入之后按照指示一步到位即可,CyberPanel安装的WP自带LSCache插件,安装完毕后进入WP后台获取QUIC Key以及打开Redis缓存即可。

但这时可能又会出现问题,我们绑定的域名可能无法访问,这时可能是httpd_config.conf并未监听IPv6,修改加上IPv6即可,同时设置HTTP跳转HTTPS,以免出现无法访问的问题

 


作 者:Serenite
链 接: https://blog.shiina.fun/2023/10/18/%e5%a4%87%e5%bf%98%ef%bc%9a%e7%ba%afipv6%e6%9d%a1%e4%bb%b6%e4%b8%8b%e5%ae%89%e8%a3%85cyberpanel%e5%bb%ba%e7%ab%8b%e4%b8%aa%e4%ba%ba%e5%8d%9a%e5%ae%a2/
来 源:Shiina's Bulog
版 权 声 明:本博客所有文章除特别声明外,均采用CC BY-NC-SA 4.0许可协议。文章版权归作者所有,未经允许请勿转载!


暂无评论

发送评论 编辑评论


|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇